PDA

View Full Version : spark plug help, ASAP!



SavageCamaro96
11-07-2009, 02:26 PM
so i changed all my spark plugs this morning and when i got done the engine is misfiring horribly,
i have no clue what i did wrong,
i changed one at a time,
all the wires are back on
theyre all gapped correctly

someone please give me some advice

is it possible that i could have broken one of the wires? or the connector?

Italia
11-07-2009, 05:18 PM
are your wires in good shape? is it possibly the coils?

michael454rs
11-07-2009, 06:25 PM
make sure you got all the wire back in there original spot maybe you got one in the wrong everytime i changed mine that was the case lol

1LOMARO
11-07-2009, 10:00 PM
Colin...check the back wire on the passenger side bro.... thats usually a common wire that never gets fully clipped in... it may feel like it is...but usually its not.... if that doesn't solve it...then your probably looking at a break in the wire depending on how old the wires are......................

tkoforpresident
11-07-2009, 10:46 PM
also, make sure they are routed correctly to your coil packs.

SavageCamaro96
11-08-2009, 12:31 AM
thanks john and max but i have done those things
im kinda thinking its the wires so i went and bought new ones while i was on break at work when i got off work and took them home i looked in the box and there was only 5 wires FML
so ill have to wait till tomorrow to try and make any progress

Need For Steve
11-08-2009, 02:23 PM
tug gently on each wire...i had a wire come completely loose inside the boot not long ago, and ran horribly with no visual indication of anything being wrong.

That, and check your plug gaps...those can screw some things up

freakv6
11-09-2009, 10:11 AM
Im with either wires routed wrong, or pulling on them made a couple go bad. Dont be to quick to say you already double checked the routing, ive seen it missed being check 4 or 5 times. Also might check or the plugs themself having a crack. the ceramic is known for cracking sometimes.

SavageCamaro96
11-09-2009, 06:03 PM
bingo forrest!
thats what it was, i cracked the #4 plug somehow
i fixed it yesterday, works good now

Bonemaro
11-09-2009, 06:11 PM
Forrest knows his stuff, by cracky!

tkoforpresident
11-13-2009, 11:57 AM
i had faith in Forrest the whole time...

bubba428
11-20-2009, 09:23 AM
sure you did TR6 boy....