PDA

View Full Version : obx shortys



redv6
05-15-2012, 02:15 AM
so i ordered some obx shortys with a y pipe. and im not mechanic guys and had no tools and started today at 10 removing my manifolds. i had a bad exhaust leak and i couldnt find it . and when i was removing my bolts i found out that on the right manifold had no bolts on at all. and its been a pain doing my own headers .but im saving myself 250 bucks. but what i want to know if the headers are worth it ? anyone have them

davidlb512
05-15-2012, 03:00 AM
Holy crap! You had an entire manifold that wasn't bolted whatsoever??? I don't believe I have ever heard of that before. Haha. I've heard a lot of good things about the short tube headers.

Throwback Bird
05-15-2012, 08:36 AM
Holey exhaust leak! How long was you driving it like that?

redv6
05-15-2012, 02:38 PM
Like 2 days . I was driving one day and all of a sudden I punched it and it didn't want to go . I checked my plugs everything my codes I had no misfire . And last night I started to change them and had one bolt on the rest fell PDF or something . I was wondering y my car was slow lol ...

Throwback Bird
05-16-2012, 12:21 AM
Well got any pics of the headers?

redv6
05-16-2012, 12:22 AM
yeah just one.

Bonemaro
05-16-2012, 12:24 AM
Show us.

redv6
05-16-2012, 02:33 AM
of the obx? and i intalled the headers already. they were a pain !!!!!!! i mean pain man. i should of paid to get them put on.now i need to get a mechanic to tighten all the bolts and im deleting my egr. so my car is out for awhile ...

3.8blackmaro
05-16-2012, 07:54 AM
The obx headers are just the eBay versions of pacesetters. They look identical.

Throwback Bird
05-16-2012, 08:29 AM
So no pics of on the car?

redv6
05-16-2012, 09:25 AM
http://i1171.photobucket.com/albums/r553/rmedrano2/IMG_07141.jpg
http://i1171.photobucket.com/albums/r553/rmedrano2/IMG_07211.jpg
http://i1171.photobucket.com/albums/r553/rmedrano2/IMG_07221-1.jpg
http://i1171.photobucket.com/albums/r553/rmedrano2/IMG_07231.jpg
http://i1171.photobucket.com/albums/r553/rmedrano2/IMG_07241.jpg

redv6
05-16-2012, 09:26 AM
i changed my rims and my grill and also took off my stripes :). but see how i had to put washers to hold the bolt. in and crap -_-

fbodyrs96
05-16-2012, 03:22 PM
what are those springs on the bolts for?

SixShooter'00Camaro
05-16-2012, 07:52 PM
Is that..... tin foil?

redv6
05-16-2012, 07:56 PM
There locking washers. We couldn't get the nut I the center do we used those to apply pressure and the bolt not come out and yeah . They gave me the msd wires like that . And one started smoking when we turned it on because of the foil .

fbodyrs96
05-16-2012, 09:40 PM
You need the 90 deg msd wires with headers.

redv6
05-17-2012, 02:09 AM
How do u know wich ones I have ? And the foil was burning not the wire

fbodyrs96
05-17-2012, 03:14 AM
Cause your plug wires are sticking straight out.

davidlb512
05-17-2012, 03:50 AM
How do u know wich ones I have ? And the foil was burning not the wire

Cause you posted pictures of them. Haha.

fbodyrs96
05-17-2012, 05:01 AM
Cause you posted pictures of them. Haha.

:lol:

Throwback Bird
05-17-2012, 08:07 AM
Yeah you do need some 90* boots on there, your gonna have problems with those. you may be able to just buy the boots with the connectors. If you got a friend that good with cars that can help you change the boots out and that would save you from spending a shit ton on new wires.

Oh by the way Ivenever seen a pic of your car, looks good.

xpbr2000
05-17-2012, 09:09 AM
yeah i've got MSD wires w/ 90deg boots and zero problems with my headers

whitdog54
05-17-2012, 02:00 PM
I actually chose to run straight wires. Only 2 of my wires I converted to 90*. I though the 90s didnt fit good in several places.

Doesnt OBX make a longtube for 3.8s? i woulda def got those.

redv6
05-18-2012, 01:01 AM
thanks my car looked similars to freaks v6 .and i have to fix all my problems before i start messing with anything i just parked her:/

redv6
05-19-2012, 02:58 AM
and i started driving it today . its bogging down when i punch it and everyonce in awhile it my oil drop and my motor shuts off? is it my cat thats clogged i think it has to be something exhaust related

xpbr2000
05-19-2012, 09:31 AM
yeah that sounds like an clogged cat. check your air filter also. the engine shutting off however sound like another problem. maybe a faulty fuel pump.

redv6
05-19-2012, 04:29 PM
egr plug i put on didnt work and it fell off. im using jb weld

xpbr2000
05-20-2012, 01:50 AM
yeah i sometimes wish i had gotten non egr headers, but these were a deal i couldn't pass up

Enzo354
05-21-2012, 07:09 PM
Did you use a bolt as well as the jb weld?

redv6
05-22-2012, 01:57 AM
nah i had a cat that was shot to hell. i changed my burnt spark plug wire and my intake. and also changed my alternator since it was going out. now no diying car. and its running way better even tho it makes a popping noise like it use to. i think some of the insides of the car got in y glass pack and is making it sound like that.

xpbr2000
05-22-2012, 09:42 AM
popping noise? like after you let off the gas? thats normal on these v6's

redv6
05-23-2012, 12:44 AM
no when i floor it. like if something is holding it back.

xpbr2000
05-23-2012, 09:09 AM
check your air filter. make sure its not caked. you've pretty much taken care of the basic other things that would cause that.

redv6
05-24-2012, 01:02 AM
i have a custom made intake . it runs good it sounds more like my muffler has something in it.

xpbr2000
05-26-2012, 01:00 AM
Maybe so, idk what kind and how old your setup is

redv6
05-26-2012, 03:33 PM
high flow cat to a glasspack dumped.

insidethreat07
05-30-2012, 12:20 AM
Which one of these would work for the wires?
http://www.autozone.com/autozone/accessories/Performance/Wireset-Performance-Boots-Terminals/_/N-26en?filterByKeyWord=plug+wires&fromString=search

fbodyrs96
05-30-2012, 01:06 AM
Idk on those but here is the
MSD part# 32799