PDA

View Full Version : Engine squeak. Please help



thegarbageman
02-07-2009, 03:57 PM
Hey, i have a 95 bird with the l32. It squeaks like crazy sometimes. the serp is only a few months old(3k miles tops) and i replaced the tensioner like last week. it doesn't make noise when i start her up but after about 5-10 of running it starts. it goes away occasionally but other times it makes the awful squeling sound. I'm thinking it's the power steering pulley or pump because i let it run and my friend and i listened as close as we could to where the noise was coming from and both settled on the pump or pulley. What can i do?
It's soooooo annoying.

Thanks!

Crazed98Camaro
02-07-2009, 05:03 PM
Does it get worse when you turn the wheel?

SpeedingFirebird
02-07-2009, 05:06 PM
sounds like the PS pulley is slightly out of line.

thegarbageman
02-07-2009, 05:33 PM
It doesn't get better or worse when i turn the wheel, or so i can tell.

i was just out driving and it started to make the noise about 5 minutes in, lasted around 10 minutes, got quieter and went away, came back but not quite as loud as before, and was barely making any noise when i pulled back into my driveway.


sounds like the PS power is slightly out of line.

Do you mean pulley? If so, how would i be able to fix is or would i have to go to napa or a GM parts place and buy a new one?

SpeedingFirebird
02-07-2009, 06:27 PM
Do you mean pulley? If so, how would i be able to fix is or would i have to go to napa or a GM parts place and buy a new one?

That depends if the pump is out of line or the pulley is out of whack. Changing just the pulley would be the easiest to try, but I would think the pump is slightly out of line.

thegarbageman
02-07-2009, 06:31 PM
OK, i'll take a look at it and see.

Thanks Speedingfirebird!

freakv6
02-09-2009, 11:19 AM
I would prolly look at a new belt just to rule that out. Had a friend with a gtp that got a belt that squeaked right from the start, and replaced it to fix the problem. Grab a piece of pipe and start he car. use the pipe to zero in on the noise. Its common on the 3.8 for the balancer to rot out and create a pretty nasty noise.