Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: super bad misfire need help

  1. #1
    Join Date
    Sep 2008
    Posts
    160
    Rep Power
    12

    Default super bad misfire need help

    so i got done with my swap and its misfiring baddddd i cant rev the engine pass 2k rpm, at idle it sounds smooth, i put new spark plugs wires coils are all sparking, got the two icm cheked and there good tried both of them and it still missfires, can this be cause by an exhaust leak somewhere say manifold for example? do these cars have some sort of timing that can be cheked? if anyone can shime in i would appreciate it

  2. #2
    Join Date
    May 2009
    Posts
    82
    Rep Power
    12

    Default

    Try mass air mine did that it would miss fire so bad it sounded like it had a huge cam in it. It didn't through a code just took a guess and unpluged it and cleard it up a little so bought a new and bam ran perfect. Bad news there 200 bucks without a core. I just had a lucky guess when mine did that.

  3. #3
    Join Date
    May 2009
    Posts
    82
    Rep Power
    12

    Default

    Also I did a Saturn engine once and one of the injectors was not on all the way it's a simple mistake. ( the plug piece)

  4. #4
    Join Date
    May 2009
    Location
    Bushnell Illinois
    Posts
    1,054
    Rep Power
    13

    Default

    Yeah I agree, somthing isn't plugged in right or in the wronge spot. Make sure you have the spark plug wires in the correct order. Double check the plugs too. Good luck

  5. #5
    Join Date
    May 2009
    Location
    Bushnell Illinois
    Posts
    1,054
    Rep Power
    13

    Default

    By any chance............Did you hear this engine run before you purchased it?

  6. #6
    Join Date
    Aug 2008
    Location
    Scottsboro, AL
    Posts
    5,627
    Rep Power
    17

    Default

    I would start simple and make sure the plug wires are in the right order (double and triple check this).

    |freakv6 12:21| bone will let people take his car out for joy rides at the g14
    |Pace 12:22| I vote we take the freak out for some joyrides.
    |freakv6 12:22| you can pace, then maybe you can drive the car afterwords

  7. #7
    Join Date
    Sep 2008
    Posts
    160
    Rep Power
    12

    Default

    i tripled cheked the wires and there going all in there correct spott, and no i dint hear the engine run before i bought it, coudl it really be the mass air flow sensor, when i turn on the car it sound smooth like nothing is wrong then i give a little rev and it pops like it misfiring all crazy, and about the injectors im going take a look today and chek to see if all of them are connected and all the way in.

  8. #8
    Join Date
    Aug 2008
    Location
    Scottsboro, AL
    Posts
    5,627
    Rep Power
    17

    Default

    You can unhook the maf...if it runs better then that is the problem.

    |freakv6 12:21| bone will let people take his car out for joy rides at the g14
    |Pace 12:22| I vote we take the freak out for some joyrides.
    |freakv6 12:22| you can pace, then maybe you can drive the car afterwords

  9. #9
    1LOMARO's Avatar
    1LOMARO is offline Captain V6F-Body Bouncer
    LS PLUS Supporting Membership
    Join Date
    Mar 2009
    Location
    Concord NC
    Posts
    3,126
    Rep Power
    15

    Default

    I would also pull the valve covers and check the valves, rocker arms,etc... one messed up valve can do the same thing

    "There is no shame in owning a V6. Anyone that makes fun of you is just upset that they spent more money than you, and their penis didn't get any bigger..."

  10. #10
    Join Date
    Sep 2008
    Posts
    160
    Rep Power
    12

    Default

    figured out the problem turns out that the sensor thats behind the harmonic balancer was messed up swapped it out and its good as new now all i have fix is leak on the manifolds and test the engine on a long trip and see how it behaves

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •