Results 1 to 8 of 8

Thread: FINALLY PUT EXHAUST ON!

  1. #1
    Join Date
    Jan 2013
    Location
    erie county, pennsylvainia
    Posts
    341
    Rep Power
    8

    Default FINALLY PUT EXHAUST ON!

    so I finally got it done and sounds good. it got put on last week but this month has been so crazy I haven't had time to do much of anything. I will post some pictures up and a sound clip later.

  2. #2
    Join Date
    Feb 2010
    Location
    Ocklawaha, Florida
    Posts
    2,927
    Rep Power
    13

    Default

    Quote Originally Posted by thake618 View Post
    so I finally got it done and sounds good. it got put on last week but this month has been so crazy I haven't had time to do much of anything. I will post some pictures up and a sound clip later.
    cool! get those pics up!
    Thanks to Dustin for my sigpic!!!
    My F-Body history: http://www.v6f-body.com/showthread.php?t=4352
    Current car: http://www.v6f-body.com/showthread.php?t=4522

  3. #3
    Join Date
    Jan 2012
    Location
    Cape Cod, MA
    Posts
    1,701
    Rep Power
    10

    Default

    Hurry up!

    Sent from my ZTE N9120 using Tapatalk 2

  4. #4
    Join Date
    Oct 2011
    Location
    Lady Lake, Florida
    Posts
    794
    Rep Power
    9

    Default


  5. #5
    Join Date
    Feb 2010
    Location
    Ocklawaha, Florida
    Posts
    2,927
    Rep Power
    13

    Default

    Quote Originally Posted by Davidbecker View Post
    Thanks to Dustin for my sigpic!!!
    My F-Body history: http://www.v6f-body.com/showthread.php?t=4352
    Current car: http://www.v6f-body.com/showthread.php?t=4522

  6. #6
    Join Date
    Sep 2009
    Location
    Renton WA
    Posts
    4,173
    Rep Power
    15

    Default

    so what exhaust did you go with?

  7. #7
    Join Date
    Oct 2011
    Location
    Lady Lake, Florida
    Posts
    794
    Rep Power
    9

    Default

    Quote Originally Posted by fbodyrs96 View Post
    so what exhaust did you go with?
    I guess the quite kind. Lmao

  8. #8
    Join Date
    Jan 2013
    Location
    erie county, pennsylvainia
    Posts
    341
    Rep Power
    8

    Default

    yea the sound wouldn't register on the camera it was so quiet. I decided to go with the slp super silent muffler lmao. No guys sorry I have been really busy lol. im gunna clean the car again lol and post some pics and a vid up, I promise. I went with the magnaflow kit. the place that put it on did a real good job mounting I have one complaint tho. they had to make the s pipe from the cat and when they bent it the pipe just looks scrunched and it just seems like it restricts airflow but it seems to sound good, has a reallll nice idle lol. the downfall to all of this is he was one of the only "reputable" shops in the area that would put on my cat and kit that I bought myself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •