Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Nas Escobar's Camaro

  1. #1
    Join Date
    Apr 2014
    Location
    Washington, DC
    Posts
    346
    Rep Power
    6

    Default Nas Escobar's Camaro

    I haven't came up with a name for her yet, despite having owned her for almost a year. I'm open to suggestions and when I come to the decision, the title will reflect that.

    So here is the nameless car.

    This is after the first day with her. I had yet to register her, but I did wash her first.







    After those pictures, the car got tagged and became my daily driver.

    The first thing I did to it was take out the stock door speakers. They sounded like ripped paper. Then again, that's exactly how I found the stock speakers to be like... there was no cone and what was left of it simply rattled. So I took the speakers from my old Grand Am and I put them in the Camaro.

    The speakers are WCC 650 component speakers. I got them on clearance in 2012.




    Don't mind the tape. I accidentally punched a hole in it so I put the tape there so it wouldn't crack. I'm going to eventually upgrade these to Alpine speakers.

    Once that was done, it was back to the daily grind.

    Pics of the car around DC.

    Capitol Building




    Anacostia in SE DC.




    I've always felt this car is very photogenic and I tend to take a lot of pictures of it, but I won't post them all because it will get boring after a while. Besides this is a transformation thread.

    After a while, I got bored of burning CD's for the stock radio. I put in my Alpine that I had in my Cutlass since at the time, the Cutlass was sitting due to a bad lower ball joint.



    It's a pretty bad ass head unit. Not the top of the line, but pretty close and it really woke up the car. It also made me realize how crappy the remaining speakers were and that I need some thump.



    So I prepped the hole (what gets called a "trunk") for some thump. I always put the T tops on top of the gas tank hump so I wasn't concerned about storage space.

    In the meantime, I took the 6x9's from my Grand Am and put them where the stock 4" speakers were in the hatch and I took my 6 1/2 JVC's out of my Cutlass (it was gutted at the time, I'll post a thread for that here if anyone's interested) and put them in the stock "sub" location. I then wired them to the rear speakers in series, so they're being powered at 8 ohm. I have no pics of that, but I'll get some later on. Interesting enough is that the rears sound better than the fronts. I assume the monsoon amp has something to do with that.

    After a while, I got a sub. Nothing major, just something off the shelf that was on clearance.





    It's a Kicker 10" L3 Solo Baric. It's not setting off alarms but it is good enough to enjoy music. It sounds like 2 entry level 12" subs. So imagine a set of Kicker Comp S or Alpine Type E's. That's how it sounds like. Not bad for a 10" sub.

    That's how far I got before I started having issues.

  2. #2
    Join Date
    Apr 2014
    Location
    Washington, DC
    Posts
    346
    Rep Power
    6

    Default Problems

    So my problems started with the serpentine belt. I was driving around and out of nowhere my steering gets hard and "check gauges" turns on.

    Old and new.



    Old


    New


    This one actually came out defective and the tensioner nearly went flying. I had to exchange it, and that created an issue with my heater hose. So after countless losses of coolant, the eventual switch to water as a cooling fluid, and issues overheating, I ended up doing the heater hose conversion.



    After that, I noticed that one issue never really went away. The water would always pool on the passenger's valley.

    It was then that I did a LIMG. I have more pictures if anyone wants an updated how to since the sticked one isn't in "how to" format but here's what triggered that "water got in my intake ports" thread.

    This is how I left it before the storms came.


    This is what happened once all the storms were gone.


    Note the 2 red circles. Water passes from the top circle and drips from the bottom circle. Interestingly enough, the weatherstripping that seals the hood is good. I have yet to figure out how to fix that one. I got a new cowl and it did nothing.

    Water drained and ready for intake gaskets. I did take off one valve cover to paint, but the other one had the pain in the ass bracket at the time.



    With all that off, I decided to paint the valve covers and plenum. They were looking pretty nasty.

    Powerwashed and lightly sanded driver's side valve cover.


    Primed


    Painted driver's side valve cover and prepped passenger's side.


    Hanging out in the sun drying. Both are painted at this point


    Prepped plenum that I had started to prime, but forgot I didn't take a pic of how it was before.


    Primed


    Painted and ready for the engine


    Valve covers on the engine. I had yet to clean the nastiness in the ports.


    Ready for the lower intake manifold. Metal gaskets for the win!


    75% put back together.


    In retrospect, I should have painted the throttle body as well. But after this, it got a new radiator, new radiator cap, switched to green antifreeze/coolant mix and got a tune up.

  3. #3
    Join Date
    Sep 2009
    Location
    Renton WA
    Posts
    4,173
    Rep Power
    14

  4. #4
    xpbr2000's Avatar
    xpbr2000 is offline Freaky Poster LS PLUS Supporting Membership
    Administrator
    Join Date
    May 2010
    Location
    Mooreville, MS
    Posts
    11,540
    Rep Power
    100

    Default

    very cool.

    I don't have a name for mine either. its not something I'm use to doing anyway.

    I see what you mean about that will rain gutter. it would run everything on the cowl into the engine bay silicone that shit

    96 Camaro Cam'd anti-Coupe
    Dyno'd @ 213 RWHP (NA)
    "OperationX"

  5. #5
    Join Date
    Jan 2012
    Location
    Cape Cod, MA
    Posts
    1,701
    Rep Power
    9

    Default

    Sweetness! Looks great. Glad you chose silver and not a crazy color. It looks nice.

  6. #6
    Join Date
    Oct 2012
    Location
    B.C Canada
    Posts
    568
    Rep Power
    7

    Default

    Keep up the good work man! Love seeing people's projects come together! That silver always looks sharp, awesome choice
    '95 3.4L Camaro-- Top end swap in progress >

  7. #7
    Join Date
    Apr 2014
    Location
    Washington, DC
    Posts
    346
    Rep Power
    6

    Default

    Thank you for all the compliments. I wanted to do the engine bay conservatively. Nothing goes best with black than accent tones, and that's why I ended up painting it silver. It looks almost factory like in real life. I'll eventually paint the accessories like the alternator and throttle. The paint's name is actually aluminum. Still came out pretty sweet though.

    So here's what I've been doing the past 2 days...



    LED bulbs. I didn't take a picture of the center nor the HVAC controls because I didn't like how they came out. I'll be getting new LED's later on.

    I did swap the cluster as well and I'm satisfied with those. I took off the plastic after taking it off to make it easier to put it in and out.


    Night shot


    I did the blinkers in LED but reverted them back to incandescent. I didn't like how bright it was.


    I had extra LEDs so I put one in the license plate light




    Now I just gotta put it all back together and fix the high beams. The stalk doesn't activate them.

  8. #8
    Join Date
    Mar 2009
    Location
    South Florida
    Posts
    537
    Rep Power
    11

    Default

    Nice work..!!!
    1993 Pontiac Firebird
    3.4L V6 / 4L60 Trans / Flowmaster Exhaust

  9. #9
    Join Date
    Apr 2014
    Location
    Washington, DC
    Posts
    346
    Rep Power
    6

    Default

    Fell off the face of the earth for a while....

    Swapped the wheels for Firebird wheels. I got these as a deal for the tires, and they were in awesome condition (no curb rash, no bends, looked almost brand new) so I put em on.

    Before:


    After:


    I've also been hitting up the yards for parts so I can move forward on my Cutlass Supreme project. So far I've hit duds but I did find this...



    They're CCFL rings and the projector sucks if anyone is wondering.

    And one more shot just because the Camaro is sexy like that.


  10. #10
    xpbr2000's Avatar
    xpbr2000 is offline Freaky Poster LS PLUS Supporting Membership
    Administrator
    Join Date
    May 2010
    Location
    Mooreville, MS
    Posts
    11,540
    Rep Power
    100

    Default

    very nice. glad to hear that you are still modding.

    i've only seen one set of aftermarket projectors on Jims car. i didn't think it was bad IMO. its much better than the 93-97 headlight setup. those factory headlamps are a joke

    96 Camaro Cam'd anti-Coupe
    Dyno'd @ 213 RWHP (NA)
    "OperationX"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •