Results 1 to 6 of 6

Thread: 7.5amp fuse blowing on the injectors. 95--3.4

  1. #1
    Join Date
    May 2017
    Posts
    3
    Rep Power
    3

    Default 7.5amp fuse blowing on the injectors. 95--3.4

    Need help. My sons 95 3.4 is blowing the passages side fuse for the injectors. Had new injectors put in and a new pmc.
    Not sure where to check .. has anyone had the problem before?
    Thanks

  2. #2
    xpbr2000's Avatar
    xpbr2000 is offline Freaky Poster LS PLUS Supporting Membership
    Administrator
    Join Date
    May 2010
    Location
    Mooreville, MS
    Posts
    11,540
    Rep Power
    100

    Default

    do they blow immediately when the car turns on? or when under throttle?

    if its immediate i'd unplug all the injectors (or at least the side that is cause the problems)
    with the key off plug one in and turn the key on to see if it blows the fuse. when you find the culprit you can diagnose it further.

    96 Camaro Cam'd anti-Coupe
    Dyno'd @ 213 RWHP (NA)
    "OperationX"

  3. #3
    Join Date
    May 2017
    Posts
    3
    Rep Power
    3

    Default

    Quote Originally Posted by xpbr2000 View Post
    do they blow immediately when the car turns on? or when under throttle?

    if its immediate i'd unplug all the injectors (or at least the side that is cause the problems)
    with the key off plug one in and turn the key on to see if it blows the fuse. when you find the culprit you can diagnose it further.
    At first it didn't blow right away.coulddrive it for a day . But now it blows right away , will have him try what u said. Thanks.

  4. #4
    xpbr2000's Avatar
    xpbr2000 is offline Freaky Poster LS PLUS Supporting Membership
    Administrator
    Join Date
    May 2010
    Location
    Mooreville, MS
    Posts
    11,540
    Rep Power
    100

    Default

    could be a short on the harness. the short may not have occurred until you drive it some and the vibration caused the short. not sure, but poosible.

    96 Camaro Cam'd anti-Coupe
    Dyno'd @ 213 RWHP (NA)
    "OperationX"

  5. #5
    xpbr2000's Avatar
    xpbr2000 is offline Freaky Poster LS PLUS Supporting Membership
    Administrator
    Join Date
    May 2010
    Location
    Mooreville, MS
    Posts
    11,540
    Rep Power
    100

    Default

    it just occurred to me that if the short is in the harness and you move the harness a little it may resolve the short or at least until it finds itself again.

    but hopefully it will be pretty straight forward.

    96 Camaro Cam'd anti-Coupe
    Dyno'd @ 213 RWHP (NA)
    "OperationX"

  6. #6
    Join Date
    May 2017
    Posts
    3
    Rep Power
    3

    Default

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •